apache无法启动服务错误1(关于“Windows不能在本地计算机启动Apache2.并参考特定服务错误代码1“问题解决)

本文目录
- 关于“Windows不能在本地计算机启动Apache2.并参考特定服务错误代码1“问题解决
- Apache启动错误1
- 不能在 本地计算机 启动 Apache Tomcat 7.0 Tomcat7请与服务厂商联系,并参考特定服务错误代码 1
- 电脑出现无法启动Apache服务器的问题如何解决
- Apache2 server 错误代码1
- Apache无法启动 检测出来一个错误,什么意思
- apache2.2 服务无法启动 发生特定错误 1 (我以把端口改为8080了)
- Apache 无法启动 错误代码1 dos 下启动显示如下代码 求解
关于“Windows不能在本地计算机启动Apache2.并参考特定服务错误代码1“问题解决
重启Apache就会弹出出错提示框,提示"The requested operation has failed!" 然后打开服务,启动Apache2,就提示我:
"Windows不能在本地计算机启动Apache2.......并参考特定服务错误代码1"
***隐藏网址***
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
#Listen 12.34.56.78:80
Listen 80
把80端口改成81或者其他的 ,
改成后,
#Listen 12.34.56.78:81080
Listen 8080
再重启ApacheServices就不会出现问题了
也许,这种方法对于不同版本的Apache可能有不同的解决方法,我在配置时是用的apache_2.2.11-win32-x86-no_ssl.msi版本的,其他版本的我不是很清楚,是不是这样改
Apache启动错误1
语法错误,请检查下d:/php/php5.dll是否存在,不行的话重新安装下php,是php的原因
不能在 本地计算机 启动 Apache Tomcat 7.0 Tomcat7请与服务厂商联系,并参考特定服务错误代码 1
1.在已解压的tomcat的bin文件夹下找到startup.bat,右击-》。在文件头加入下面两行:
SET JAVA_HOME=D:\Java\jdk1.6.0_10 (java jdk目录)
SET TOMCAT_HOME=E:\tomcat-6.0.35 (解压后的tomcat文件目录)
2.同样的。在已解压的tomcat的bin文件夹下找到shutdown.bat,右击-》。在文件头加入下面两行:
SET JAVA_HOME=D:\Java\jdk1.6.0_10 (java jdk目录)
SET TOMCAT_HOME=E:\tomcat-6.0.35 (解压后的tomcat文件目录)
3.将你要发布/部署的web文件复制到tomcat的webapps目录下。
4.双击startup.bat即可启动tomcat,成功启动。
电脑出现无法启动Apache服务器的问题如何解决
1、按Win+R键打开运行,cmd并回车;
2、打开命令提示符后,输入“netstat -ano”,按回车键,查看端口的使用情况;
3、右击任务栏,选择“启动任务管理器”,在进程中,查看PID一栏中占用软件端口的进程,并选中点击结束进程即可;
4、如果仍没有解决问题,则打开“网络和共享中心”——“更改适配器设置”;
5、右击打开“本地连接”属性;
6、打开TCP/IPv4属性,点击“高级”;
7、切换到“WINS”,取消勾选“启用LMHOSTS查找”,并点击确定即可。
当遇到电脑中无法启动Apache服务器的问题时,可以按照上述介绍的步骤进行解决。
Apache2 server 错误代码1
在网上找的第一个方法(详细一点的):如下:
apache2 +subversion 配置apache作为server,
当配置文件告诉apache, subversion库地址URL后,apache服务无法启动了.
报错信息: "windows不能在本地计算机启动apache2.有关更多信息,查阅系统事件日志。如果这是非microsoft服务,请与服务厂商联系,并参考特定服务错误代码1".
------------------------------------------------------
1)os: windowsXP+sp2
2)install: apache v2.0.59 (端口:80)
svn_v1.4.0
(注:我试过 apache 2.2.3 +svn1.4.0, 结果到 loadModule 就无法配置成功了,各位同仁吸取教训,不要用apache 2.2.3 )
3) apache正常启动
***隐藏网址***
4)拷贝 mod_dav_svn.so和mod_authz_svn.so这两个文件到 D:\Program Files\Apache Group\Apache2\modules目录下
拷贝Subversion\bin下面的 libdb44.dll,libeay32.dll,ssleay32.dll到D:\Program Files\Apache Group\Apache2\modules目录下。
***隐藏网址***
以下两句去掉注释:
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
在LoadModule节最后,增加下面两行:
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so
***隐藏网址***
# Example:
# LoadModule foo_module modules/mod_foo.so
#
LoadModule access_module modules/mod_access.so
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_module modules/mod_auth.so
#LoadModule auth_anon_module modules/mod_auth_anon.so
#LoadModule auth_dbm_module modules/mod_auth_dbm.so
#LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule autoindex_module modules/mod_autoindex.so
#LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
#LoadModule expires_module modules/mod_expires.so
#LoadModule file_cache_module modules/mod_file_cache.so
#LoadModule headers_module modules/mod_headers.so
LoadModule imap_module modules/mod_imap.so
LoadModule include_module modules/mod_include.so
#LoadModule info_module modules/mod_info.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
#LoadModule mime_magic_module modules/mod_mime_magic.so
#LoadModule proxy_module modules/mod_proxy.so
#LoadModule proxy_connect_module modules/mod_proxy_connect.so
***隐藏网址***
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule negotiation_module modules/mod_negotiation.so
#LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule speling_module modules/mod_speling.so
#LoadModule status_module modules/mod_status.so
#LoadModule unique_id_module modules/mod_unique_id.so
LoadModule userdir_module modules/mod_userdir.so
#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule ssl_module modules/mod_ssl.so
#
# ExtendedStatus controls whether Apache will generate "full" status
# information (ExtendedStatus On) or just basic information (ExtendedStatus
# Off) when the "server-status" handler is called. The default is Off.
#
#ExtendedStatus On
# yuanyuan add 2007-1-11
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so
6)至此,重启apache服务,一切正常
***隐藏网址***
7)按照 tortoiseSVN 1.4.0 帮助手册,配置apache+subversion
***隐藏网址***
《Location /svn》
DAV svn
SVNListParentPath on
SVNParentPath d:/svndatabase/testproject
AuthType Basic
AuthName "subversion repositories"
AuthUserFile passwd
#AuthzSVNAccessFile svnaccessfile
Require valid-user
《/Location》
其中:d:/svndatabase/testproject 是本地建好的subversion数据库路径(FSFS格式)
8)在命令提示符界面下 输入以下的命令行用来创建passwd 数据库认证文件
bin\htpasswd -c passwd 《username》
输入口令。
结果在D:\Program Files\Apache Group\Apache2\bin下看到生成了passwd文件,
写有用户名称,加密后的密码。
9)到此,预期结果是: 重启apache服务,成功后.
***隐藏网址***
实际结果是: 在monitor apache server,重启apache服务,失败。
***隐藏网址***
---------------------------------------------------------------
运行 test configuration ,通过。 但apache2服务无法启动。
报错:"windows不能在本地计算机启动apache2.有关更多信息,查阅系统事件日志。如果这是非microsoft服务,请与服务厂商联系,并参考特定服务错误代码1"
***隐藏网址***
***隐藏网址***
又在网上查 apache错误代码,没有找到。
看了以上这些信息,各位同仁能看出问题出在哪里吗?
或者我应该怎么做能定位到错误所在。
***隐藏网址***
《Location /svn》
DAV svn
SVNListParentPath on
SVNParentPath d:/svndatabase/testproject
AuthType Basic
AuthName "subversion repositories"
AuthUserFile passwd
#AuthzSVNAccessFile svnaccessfile
Require valid-user
《/Location》
***隐藏网址***
另外一个方法如下:
***隐藏网址***
安装完apache后,启动它时出现这样的错误信息:
windows不能在本地计算机启动 Apache2.2。有关更多信息,查阅系统事件日志。如果这是非Microsoft服务,请与服务厂商联系,并参考特定服务错误代码1。
--------------------------------------------------------------
解决办法如下:
***隐藏网址***
2、进入系统服务,启动Apache2服务
3、
***隐藏网址***
说明已经成功解决问题
如果不行,看看80端口是不是被其它占用了。
Apache无法启动 检测出来一个错误,什么意思
针对这个问题:
1、首先确认用了CMD发现以上,如果提示以上“a valid directory”,检查文件路径是否全英文,如是,首先关闭xampp,然后重命名,如出现占用,重启再改;
***隐藏网址***
3、以上不行,请重装XAMPP;
apache2.2 服务无法启动 发生特定错误 1 (我以把端口改为8080了)
这个错误都是你APACHE配置文件错误造成的,在系统的错误报告里找错误提示,它会告诉你是配置文件的哪行错了。
右键我的电脑-管理-事件查看器,看里面的错误报告
Apache 无法启动 错误代码1 dos 下启动显示如下代码 求解
apache2没有安装成功!windows系统建议使用apmserv软件。配置比较简单!

更多文章:
跷二郎腿太低好吗?想要通过贴墙站改正二郎腿影响的话,有哪些要点需要注意
2026年10月11日 05:10
易语言点击js按钮(易语言网页填表怎样点击链接为“javascript:void(0)“的按钮)
2026年10月11日 03:00
compare with造句(用compared with和compared to造句)
2026年10月10日 23:30
tensorflow与keras对应版本(为什么tensorflow2.8没有keras)
2026年10月10日 22:10
maven仓库jar网站(如何在maven仓库中添加jar包)
2026年10月10日 19:50







